Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
An issue with a longer name that might not fit well in the alert box
Resolved
·
Partial outage
done
Wed, Mar 11, 2026, 01:54 PM
(
1
week ago)
·
View all updates
Affected components
Feb 23, 2026, 01:12 PM
Mar 11, 2026, 01:54 PM
Integrations
1 affected component
Updates
Resolved
done
Wed, Mar 11, 2026, 01:54 PM
Investigating
The message that describes this incident
Mon, Feb 23, 2026, 01:12 PM
(
2
weeks earlier)
An issue with a longer name that might not fit well in the alert box - Sendcloud test Status