Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Something broke
Resolved
·
Full outage
Reverted the issue
Tue, Feb 24, 2026, 08:25 AM
(
3
weeks ago)
·
View all updates
Affected components
Feb 24, 2026, 08:24 AM
08:25 AM
Sendcloud
1 affected component
Updates
Resolved
Reverted the issue
Tue, Feb 24, 2026, 08:25 AM
Investigating
It broke, and we all know who broke it 🤖
Tue, Feb 24, 2026, 08:24 AM
Something broke - Sendcloud test Status