Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Third party incident - DHL Express - Label announcement issues
Resolved
·
Full outage
Now resolved
Fri, Apr 10, 2026, 02:34 PM
(
1
month ago)
·
View all updates
Affected components
Apr 10, 2026, 02:13 PM
02:34 PM
Carriers
1 affected component
Affected market
1 affected component
Updates
Resolved
Now resolved
Fri, Apr 10, 2026, 02:34 PM
Investigating
Third party incident - DHL Express - Label announcement issues
Fri, Apr 10, 2026, 02:13 PM
(
21
minutes earlier)
Third party incident - DHL Express - Label announcement issues - Sendcloud test Status